Text Groove - Text Groove Support Phone Number is Offline – Incident details

Text Groove Support Phone Number is Offline

Resolved
Operational
Started about 2 months agoLasted 5 days

Affected

Text Groove Application

Degraded performance from 7:01 PM to 10:02 PM

Updates
  • Resolved
    Resolved

    The incident with our Toll Free number has been resolved. Thank you.

  • Investigating
    Investigating

    We are currently investigating this incident.

    You may or may not be able to reach us on our toll-free number. Please reach out to support@textgroove.com for support.

    Thank you